This project is read-only.

Using in MultiThreaded

Oct 15, 2014 at 5:54 PM
I used your RunMultipleInstancesSample ... very carefully. the "constructor 'fromMemory' option is set to true". Unfortunately only one PS file is being created. The start time of the threads is being logged. The start and end time of the process it calls that does the GhostScript processing is being logged. No exceptions are detected.
The one PostScript file it generates is fine. It is the first file processed that is created. The second is never made.
I would appreciate any suggestions. I've been testing this with a standard wrapper and got the same result, that is why I tried GhostScript.Net. It says it can do multi-threaded. I just can't get it to.
I do not want to have to re-build the GostScript DLL for multi-thread, but if I cannot get this fixed up, I will have to and that looks un fun.

Thank you for any help or suggestions you might have, Mike
Oct 20, 2014 at 9:11 PM

It would be good if you could post some code and sample files so I could see and test.

Oct 21, 2014 at 9:02 PM
Edited Oct 21, 2014 at 9:15 PM
Greetings Josip,

Thank you for your prompt reply. I was trying to figure out how to communicate it to you as the code is pretty involved. I started working through it and this time it seemed to work. Will it keep working? Not positive, but for now it seemed to work multi-threaded. ... Now if it just keeps working that way!!!!!!

Thanks Mike

... I just realized. Is version 9.15 inherently multi-threaded? We were using version 9.08 and it had to be recompiled with a flag for multi-threaded.